إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

مشكله في اضافه الجافا كـ plugin لـ mozilla

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • مشكله في اضافه الجافا كـ plugin لـ mozilla

    تثبيت الجفا مع الفيدورا عقدني و لله


    المشكله الي واجهتها إضافت الجافا كـ plugin لمتصفح mozilla الـ firefox

    اتسخدمت الطريقة التاليه

    أول شئ حملت الجافا من موقع java.com

    و بعدين استخدمت الامر التالي

    ./jre-6u1-linux-i586-rpm.bin
    بعد التنصيب استخدمت الامر التالي

    ln -s /usr/java/jar1.6.0_01/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/libjavaplugin_oji.so
    لكن للأسف حاولت تجربة الدخول على الايرسي جافا علشان أتأكد ان الخطوات سليمه .. بس ما فتح الشات


    دورت عن حلول بجوجل حصلت كل المواضيع نفس طريقة التثبيت الي ذكرتها !!!


    الي عنده تصحيح لي ياليت يفيدني ... و شاكر لجهودكم مقدماً

  • #2
    في هذه الصفحة http://www.fedorafaq.org/#java ستجد الحل ان شاء اللله

    تعليق


    • #3
      يعطيك العافيه عزيزي yast

      لما اتبع الخطوه التاسعه يصادفني رسالة خطء

      [
      كود PHP:
      root@silent silent]# yumdownloader --enablerepo=jpackage-nonfree java-1.5.0-sun
      Loading "installonlyn" plugin
      Traceback 
      (most recent call last):
        
      File "/usr/bin/yumdownloader"line 190in <module>
          
      util YumDownloader()
        
      File "/usr/bin/yumdownloader"line 41in __init__
          self
      .main()
        
      File "/usr/bin/yumdownloader"line 49in main
          opts 
      self.doUtilConfigSetup()
        
      File "/usr/share/yum-cli/utils.py"line 69in doUtilConfigSetup
          
      (optsself.cmds) = self._parser.setupYumConfig()
        
      File "/usr/share/yum-cli/cli.py"line 1141in setupYumConfig
          self
      .base.repos.enableRepo(repoexp)
        
      File "/usr/lib/python2.5/site-packages/yum/repos.py"line 113in enableRepo
          thisrepo 
      self.getRepo(repoid)
        
      File "/usr/lib/python2.5/site-packages/yum/repos.py"line 68in getRepo
          
      'Error getting repository data for %s, repository not found' % (repoid)
      yum.Errors.RepoErrorError getting repository data for jpackage-nonfreerepository not found 


      عندك أي خلفيه عن سبب الرساله هذي !!!

      تعليق


      • #4
        http://www.linuxac.org/forum/showthr...E1%CC%C7%DD%C7

        تعليق


        • #5
          مشكور اخوي عبدالعزيز

          استفدت كثير من الموضوع بحاول و لي رجعه

          تعليق


          • #6
            اخوي عبدالعزيز

            رجعت للرابط و تتبعت الموضوع مع اللردود

            انت ذكرت ...

            المشاركة الأصلية بواسطة عبد العزيز مشاهدة المشاركة
            يسسسسسسسس

            يعيش سفاح النت ويسقط الفايرفوكس هو والجافا

            الحمدلله اشتغلت بواسطة هذا الامر

            كود:
            [email protected]:~/.firefox/plugins> ln -s /usr/lib/java/jre/plugin/i386/[COLOR="Red"]ns610-gcc32[/COLOR]/libjavaplugin_oji.so
            [email protected]:~/.firefox/plugins> ls
            libjavaplugin_oji.so  libnullplugin.so
            [email protected]:~/.firefox/plugins>
            شايفين اللي في اللون الاحمر هذا ، هو كان مشكلتي ، لأنه يوجد ثلاث مجلدات كل واحد فيهم موجود فيه plugin

            جربت الاول وهو ns4 ورفض ، جربت الثاني وهو ns610 وكل مافتح صفحة فيها جافا يتقفل الفايرفوكس crash

            وبالاخير جربت هذا ns610-gcc32 واشتغل معي زي الحلاوه

            ونفس ماذكر سفاح كنت في مجلد البلوق انز للاصدار الجديد


            شاكر لكم جميعا ياشباب

            لكن مش موجود عندي المجلد الي ذكرته في ردك السابق !!!

            بعد تثبيتي للجافا ظهر عندي مجلدين


            كود PHP:
            [silent@silent ~]$ ls /usr/lib/java/jre*/plugin/i386
            ns7      ns7
            -gcc29 
            اخترت بالأول الأمر التالي للربط بالمجلد الاول ns7-gcc29

            كود PHP:
            ln -/usr/lib/java/jre*/plugin/i386/ns7-gcc29/libjavaplugin_oji.so 


            لما افتح البروزر firefox ... يقفل علي من دون سبب .. و انت ذكرت ان نفس العمليه صارت معك

            رجعت و جربت الربط بالمجلد ns7

            كود PHP:
            ln -/usr/lib/java/jre/plugin/i386/ns7/libjavaplugin_oji.so 

            لما افتح الفيرفوكس و اروح على اي جافا شات سواء ايرسي و لا دجي ..

            البروزر ما يطلب مني تثبيت الجافا و هذا شئ ممتاز
            بس ما يشتغل معي الشات أو اي تطبيق جافا

            المشكله هذي ما وجهتها الا بالفيدورا من كور 5 الى الحين كور 7 استخدم
            و لا عرفت لها حل

            علشان كذا اضطريت احول للتوزيعات الثانيه مثل ايوبنتوا و السوزي ....


            =======

            ما ادري ليه المجلد الي ذكرته ns610-gcc32 مو موجود عندي بعد التثبيت

            انا نزلت الجافا من موقعها الرسمي

            اذا كنت منزلها من موقع ثاني ياليت تكتب لي الرابط

            بإنتظار ردودكم

            تعليق


            • #7
              للحين ما فيه رد

              المجلد الي ذكره الاخ عبدالعزيز فعلا مش موجود بالاصدارات الجديده من الجافا

              Use the copy located in the plugin/i386/ns7 directory of JRE 5.0 or later, or plugin/i386/ns610-gcc32 if you are using JRE 1.4.2
              .

              الاصدار الي استخدمه "jre-1.6.0_01-fcs"

              على العموم فتحت الفيرفوكس عن طريق الشل و دخلت على موقع فيه تطبيقات جافا
              و طلع معي الخطء التالي
              كود PHP:

              [root@silent firefox-2.0.0.4]# ./firefox-bin
              java.lang.UnsatisfiedLinkError: /usr/java/jre1.6.0_01/lib/i386/libdeploy.solibstdc++.so.5cannot open shared object fileNo such file or directory
                      at java
              .lang.ClassLoader$NativeLibrary.load(Native Method)
                      
              at java.lang.ClassLoader.loadLibrary0(Unknown Source)
                      
              at java.lang.ClassLoader.loadLibrary(Unknown Source)
                      
              at java.lang.Runtime.load0(Unknown Source)
                      
              at java.lang.System.load(Unknown Source)
                      
              at com.sun.deploy.config.UnixConfig.loadLibDeploy(Unknown Source)
                      
              at com.sun.deploy.config.UnixConfig.<clinit>(Unknown Source)
                      
              at com.sun.deploy.config.ConfigFactory.newInstance(Unknown Source)
                      
              at com.sun.deploy.config.Config.getInstance(Unknown Source)
                      
              at com.sun.deploy.config.Config.<clinit>(Unknown Source)
                      
              at sun.plugin.util.PluginConfig.<init>(Unknown Source)
                      
              at sun.plugin.util.UserProfile.<clinit>(Unknown Source)
                      
              at sun.plugin.AppletViewer.loadPropertiesFiles(Unknown Source)
                      
              at sun.plugin.JavaRunTime.initEnvironment(Unknown Source)
                      
              at sun.plugin.navig.motif.Plugin.doit(Unknown Source)
                      
              at sun.plugin.navig.motif.Plugin.start(Unknown Source)
              Exception in thread "SysExecutionThead" java.lang.NoClassDefFoundErrorCould not initialize class com.sun.deploy.config.Config
                      at com
              .sun.deploy.ui.DialogTemplate.deriveParent(Unknown Source)
                      
              at com.sun.deploy.ui.DialogTemplate.<init>(Unknown Source)
                      
              at com.sun.deploy.ui.UIFactory$3.execute(Unknown Source)
                      
              at sun.plugin.util.PluginSysUtil$SysExecutionThread.run(Unknown Source)
              Could not read ack from child process
              Plugin
              Java VM process has died.
              pluginjava process exited with status 6
              Could not start JavaVM
              !

              VM did not start up properly
              java
              .lang.UnsatisfiedLinkError: /usr/java/jre1.6.0_01/lib/i386/libdeploy.solibstdc++.so.5cannot open shared object fileNo such file or directory
                      at java
              .lang.ClassLoader$NativeLibrary.load(Native Method)
                      
              at java.lang.ClassLoader.loadLibrary0(Unknown Source)
                      
              at java.lang.ClassLoader.loadLibrary(Unknown Source)
                      
              at java.lang.Runtime.load0(Unknown Source)
                      
              at java.lang.System.load(Unknown Source)
                      
              at com.sun.deploy.config.UnixConfig.loadLibDeploy(Unknown Source)
                      
              at com.sun.deploy.config.UnixConfig.<clinit>(Unknown Source)
                      
              at com.sun.deploy.config.ConfigFactory.newInstance(Unknown Source)
                      
              at com.sun.deploy.config.Config.getInstance(Unknown Source)
                      
              at com.sun.deploy.config.Config.<clinit>(Unknown Source)
                      
              at sun.plugin.util.PluginConfig.<init>(Unknown Source)
                      
              at sun.plugin.util.UserProfile.<clinit>(Unknown Source)
                      
              at sun.plugin.AppletViewer.loadPropertiesFiles(Unknown Source)
                      
              at sun.plugin.JavaRunTime.initEnvironment(Unknown Source)
                      
              at sun.plugin.navig.motif.Plugin.doit(Unknown Source)
                      
              at sun.plugin.navig.motif.Plugin.start(Unknown Source)
              Exception in thread "SysExecutionThead" java.lang.NoClassDefFoundErrorCould not initialize class com.sun.deploy.config.Config
                      at com
              .sun.deploy.ui.DialogTemplate.deriveParent(Unknown Source)
                      
              at com.sun.deploy.ui.DialogTemplate.<init>(Unknown Source)
                      
              at com.sun.deploy.ui.UIFactory$3.execute(Unknown Source)
                      
              at sun.plugin.util.PluginSysUtil$SysExecutionThread.run(Unknown Source)
              Could not read ack from child process
              Plugin
              Java VM process has died.
              Could not start JavaVM


              بنتظار حلولكم

              تعليق


              • #8
                الحمد لله انحلت المشكله

                ثبت libstdc++.so.5

                من أول سطر بالخطء الي ظهر لي بالشل

                كود PHP:
                java.lang.UnsatisfiedLinkError: /usr/java/jre1.6.0_01/lib/i386/libdeploy.solibstdc++.so.5cannot open shared object fileNo such file or directory 

                جربت الامر

                yum install libstdc++.so.5

                طبعا الف شكر لي yast و عبدالعزيز لمحاولتهم تقديم الحلول ;-)

                تعليق

                يعمل...
                X