إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

مشكلة عمل كومبايل لبرنامج cryptkeeper

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [تم حل المشكلة] مشكلة عمل كومبايل لبرنامج cryptkeeper

    السلام عليكم ورحمة الله وبركاته

    كنت أود تنصيب برنامج cryptkeeper على توزيعتي الجديدة، ولكن للأسف ظهرت عندي مشاكل كان لابد من حلها لكي أستطيع تركيب البرنامج ...

    البرنامج ببساطة عبارة عن حاجة مشابهة لما قام به الأخ مؤيد مشكوراً "خزنة أعجوبة الشخصية" ... صدقاً لم اعرف بذلك البرنامج سوى أول أمس ولهذا كنت خلاص مبلوش في حل مشكلة cryptkeeper أصلاً ...

    المهم توزيعتي هي Fedora 13 - x86_64 ... وعند محاولتي عمل كومبايل له ظهرت التالي:
    كود:
    /usr/bin/ld: note: 'XFlush' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
    /usr/lib64/libX11.so.6: could not read symbols: Invalid operation
    collect2: ld returned 1 exit status
    make[2]: *** [cryptkeeper] Error 1
    make[2]: Leaving directory `/home/username/Desktop/cryptkeeper-0.9.5/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/username/Desktop/cryptkeeper-0.9.5'
    make: *** [all] Error 2

    وكان لابد من إيجاد حل ولهذا بعد المحاولات العديدة قمت بالحل بالطريقة التالية ... حرر الملف:
    كود:
    vim src/Makefile.in

    ومن ثم قم بالبحث عن:
    كود:
    CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) \

    وحولها الى:
    كود:
    CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -lX11 -ldl -lXext \

    ومن ثم احفظ الملف وأعد عملية الكونفيغ:
    كود:
    ./configure

    ومن ثم أعمل الكومبايل مرة أخرى:
    كود:
    make

    وبعدها تنصيبه بصلاحيات المستخدم root كالعادة:
    كود:
    make install

    وخلاص ... موفقين إن شاء الله ...
    إِنَّمَـا الأُمَـمُ الأَخْـلاقُ مَا بَقِيَـتْ ... فَـإِنْ هُمُ ذَهَبَـتْ أَخْـلاقُهُمْ ذَهَبُـوا

    إذا المرء لا يرعاك إلا تكلفاً ... فدعه ولا تكثر عليه التأسفا
    ففي الناس أبدال وفي الترك راحة ... وفي القلب صبر للحبيب ولو جفا
    فما كل من تهواه يهواك قلبه ... ولا كل من صافيته لك قد صفا
    إذا لم يكن صفو الوداد طبيعة ... فلا خير في خل يجيء تكلفا
    ولا خير في خل يخون خليله ... ويلقاه من بعد المودة بالجفا
    وينكر عيشاً قد تقادم عهده ... ويظهر سراً كان بالأمس في خفا

    [ مواقع مفيدة: أروع موقع القرآن الكريم |مدونتي |Twitter |نظام طارق ]


  • #2
    مشكور مهندسنا على الموضوع .
    البرنامج عندما أعمل ليه configure يطلع لي نقص في
    checking for DEP... configure: error: Package requirements (gtk+-2.0 >= 2.8 gconf-2.0) were not met:

    No package 'gtk+-2.0' found
    No package 'gconf-2.0' found
    ثبت الـ gtk2-devel والحمد لله حلت الأولى ، بقي حزمة gconf والتي لم أجدها في المخازن ، ما العمل ؟
    checking for DEP... configure: error: Package requirements (gtk+-2.0 >= 2.8 gconf-2.0) were not met:

    No package 'gconf-2.0' found

    تعليق


    • #3
      بسم الله الرحمن الرحيم

      الحل هنا :
      http://www.linuxac.org/forum/showthr...E3%C8%C7%ED%E1
      (لَا تَحْسَبَنَّ الَّذِينَ يَفْرَحُونَ بِمَا أَتَوا وَّيُحِبُّونَ أَن يُحْمَدُوا بِمَا لَمْ يَفْعَلُوا فَلَا تَحْسَبَنَّهُم بِمَفَازَةٍ مِّنَ الْعَذَابِ وَلَهُمْ عَذَابٌ أَلِيمٌ)
      آل عمران 188
      قال رسول الله صلى الله عليه و سلم :
      {لا يشكر الله من لا يشكر الناس}
      {من كان يؤمن بالله واليوم الآخر،فليقل خيراً أو ليصمت}

      جميع المساهمات الحاملة لهذا التوقيع تخضع لرخصة وقف
      أسأل الله العظيم رب العرش العظيم أن يحسن من حال أمتي

      تعليق


      • #4
        الحمد لله تم الحل بتثبيت التالي بالطريقة التالية
        كود PHP:
        su -'yum install gtk2-devel GConf2 GConf2-devel' 

        تعليق


        • #5
          المشاركة الأصلية بواسطة pasem_haj مشاهدة المشاركة
          مشكور مهندسنا على الموضوع .
          البرنامج عندما أعمل ليه configure يطلع لي نقص في
          checking for DEP... configure: error: Package requirements (gtk+-2.0 >= 2.8 gconf-2.0) were not met:

          No package 'gtk+-2.0' found
          No package 'gconf-2.0' found
          ثبت الـ gtk2-devel والحمد لله حلت الأولى ، بقي حزمة gconf والتي لم أجدها في المخازن ، ما العمل ؟
          checking for DEP... configure: error: Package requirements (gtk+-2.0 >= 2.8 gconf-2.0) were not met:

          No package 'gconf-2.0' found
          كود:
          yum install GConf2-devel ghc-gconf-devel

          تعليق


          • #6
            السلام عليكم و رحمة الله تعالى و بركاته،

            البرنامج سيكون في مستودعات فيدورا في غضون أيام


            في أمان الله

            تعليق

            يعمل...
            X