إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

واجهة فاير فوكس تحولت للغة الإنجليزية

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [مشكلة] واجهة فاير فوكس تحولت للغة الإنجليزية

    تحولت واجهة متصفح الفاير فوكس لدي فجأة من اللغة العربية للإنجليزية ...
    كيف أعيدها للعربية ؟!

  • #2
    بسم الله الرحمن الرحيم

    ليس فجأة قد تكون حدثته أو شيء من هذا القبيل ،

    ما النظام المستخدم واصدار فير فوكس ؟
    (لَا تَحْسَبَنَّ الَّذِينَ يَفْرَحُونَ بِمَا أَتَوا وَّيُحِبُّونَ أَن يُحْمَدُوا بِمَا لَمْ يَفْعَلُوا فَلَا تَحْسَبَنَّهُم بِمَفَازَةٍ مِّنَ الْعَذَابِ وَلَهُمْ عَذَابٌ أَلِيمٌ)
    آل عمران 188
    قال رسول الله صلى الله عليه و سلم :
    {لا يشكر الله من لا يشكر الناس}
    {من كان يؤمن بالله واليوم الآخر،فليقل خيراً أو ليصمت}

    جميع المساهمات الحاملة لهذا التوقيع تخضع لرخصة وقف
    أسأل الله العظيم رب العرش العظيم أن يحسن من حال أمتي

    تعليق


    • #3
      لم اقم بتحديثه ولم اغير اي شيء به .. اعمل على اعجوبة 4
      فتحت فاير فوكس وفي اقل من ثانية تغيرت واجهتة للإنجليزية
      واسم الحزمة من اضافة وازالة البرامج كما هي لدي :
      (firefox-3.6.7-1fc13 (×86_64

      تعليق


      • #4
        أولا، افتح سطر الأوامر و نفد ما يلي:
        كود:
        locale
        ثم أكتب لنا المخرجات حتى يسهل التدقيق في المشكلة لاحقا إذا استمرت.

        بعدها أغلق فايرفوكس و من ثم على سطر الأوامر نفذ:
        كود:
        export LC_ALL=ar_EG.UTF-8
        
        ثم من نفس نافدة سطر الأوامر نفد
        
        firefox
        إذا ظهر فايرفوكس بالعربية عليك فقط أن تعدل ملف i18n

        باستخدام المدير root أو صلاحيات sudo افتح الملف
        كود:
        /etc/sysconfig/i18n
        ثم عدل قيمة LANG و LC_ALL لتصبح كالتالي:
        كود:
        LANG=ar_EG.UTF-8
        LC_ALL=ar_EG.UTF-8
        ملاحظة: أنا افترضت أنك من مصر لذلك استخدمت EG إذا كنت من دولة أخرى غير EG أعلاه بالحرفين اللذين يمثلا دولتك.
        ArabicFOSS
        انضم إلى فريق المدونة و ساهم بما شئت وقتما شئت!

        تعليق


        • #5
          [QUOTE=محمد البردعي;350127]أولا، افتح سطر الأوامر و نفد ما يلي:
          كود:
          locale
          ثم أكتب لنا المخرجات حتى يسهل التدقيق في المشكلة لاحقا إذا استمرت.

          بعدها أغلق فايرفوكس و من ثم على سطر الأوامر نفذ:
          كود:
          export LC_ALL=ar_EG.UTF-8
          
          ثم من نفس نافدة سطر الأوامر نفد
          
          firefox
          إذا ظهر فايرفوكس بالعربية عليك فقط أن تعدل ملف i18n

          لم يتغير شيء
          وهذه المخرجات
          كود:
          [[email protected] ~]$ locale
          LANG=ar_SA.utf8
          LC_CTYPE="ar_SA.utf8"
          LC_NUMERIC="ar_SA.utf8"
          LC_TIME="ar_SA.utf8"
          LC_COLLATE="ar_SA.utf8"
          LC_MONETARY="ar_SA.utf8"
          LC_MESSAGES="ar_SA.utf8"
          LC_PAPER="ar_SA.utf8"
          LC_NAME="ar_SA.utf8"
          LC_ADDRESS="ar_SA.utf8"
          LC_TELEPHONE="ar_SA.utf8"
          LC_MEASUREMENT="ar_SA.utf8"
          LC_IDENTIFICATION="ar_SA.utf8"
          LC_ALL=
          [[email protected] ~]$

          تعليق


          • #6
            ماهى مخرجات
            كود PHP:
            cat /usr/bin/firefox grep -i lang 

            تعليق


            • #7
              المشاركة الأصلية بواسطة إيهاب الجداوى مشاهدة المشاركة
              ماهى مخرجات
              كود PHP:
              cat /usr/bin/firefox grep -i lang 
              كود:
              [[email protected] ~]$ cat /usr/bin/firefox | grep -i lang
              # implied. See the License for the specific language governing
              MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
              ## To disable the use of Firefox localization, set MOZ_DISABLE_LANGPACKS=1
              # MOZ_DISABLE_LANGPACKS=1
              # export MOZ_DISABLE_LANGPACKS
              ## Automatically installed langpacks are tracked by .fedora-langpack-install
              FEDORA_LANGPACK_CONFIG="$MOZ_EXTENSIONS_PROFILE_DIR/.fedora-langpack-install"
              # MOZ_DISABLE_LANGPACKS disables language packs completelly
              if ! [ $MOZ_DISABLE_LANGPACKS ] || [ $MOZ_DISABLE_LANGPACKS -eq 0 ]; then
              # Modify language pack configuration only when firefox is not running 
              # and language packs are not disabled
                  # Clear already installed langpacks
                  if [ -f $FEDORA_LANGPACK_CONFIG ]; then
                      rm `cat $FEDORA_LANGPACK_CONFIG` > /dev/null 2>&1
                      rm $FEDORA_LANGPACK_CONFIG > /dev/null 2>&1
                  CURRENT_LOCALE=${CURRENT_LOCALE:-$LANG}
                  # Try to link global langpacks to an extension directory
                  if [ -f $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar ]; then
                      if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org ]; then
                          rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org" > /dev/null 2>&1
                      if ! [ -e $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org ]; then
                          ln -s $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org \
                                $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org
                          echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org" > $FEDORA_LANGPACK_CONFIG
                  elif [ -f $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar ]; then
                      if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org ]; then
                          rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org" > /dev/null 2>&1
                      if ! [ -e $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org ]; then
                          ln -s $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org \
                                $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org
                          echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org" > $FEDORA_LANGPACK_CONFIG
                  if [ -f $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar ]; then
                      if [ -f $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar ]; then
              [[email protected] ~]$

              تعليق


              • #8
                طيب نفذ
                كود PHP:
                LANG=ar_EG.utf8 && firefox 

                تعليق


                • #9
                  المشاركة الأصلية بواسطة إيهاب الجداوى مشاهدة المشاركة
                  طيب نفذ
                  كود PHP:
                  LANG=ar_EG.utf8 && firefox 
                  اشكرك اخي ... ولكن للأسف لم يتغير شيء ايضآ

                  تعليق


                  • #10
                    خذ نسخة إحتياطية من دليل إعدادات فيرفوكس فى المنزل ستجده فى هذا المسار
                    كود PHP:
                    /home/$USERNAME/.mozilla 
                    وقم بحزفه ثم تشغيل فيرفوكس

                    تعليق


                    • #11
                      المشاركة الأصلية بواسطة إيهاب الجداوى مشاهدة المشاركة
                      خذ نسخة إحتياطية من دليل إعدادات فيرفوكس فى المنزل ستجده فى هذا المسار
                      كود PHP:
                      /home/$USERNAME/.mozilla 
                      وقم بحزفه ثم تشغيل فيرفوكس
                      @إيهاب الجداوى ، هذا سيحذف إضافات فايرفوكس

                      تعليق


                      • #13
                        المشاركة الأصلية بواسطة haytham-med مشاهدة المشاركة
                        @إيهاب الجداوى ، هذا سيحذف إضافات فايرفوكس
                        تم التنبيه على أخذ نسخة إحتياطية !

                        تعليق


                        • #14
                          المشاركة الأصلية بواسطة إيهاب الجداوى مشاهدة المشاركة
                          خذ نسخة إحتياطية من دليل إعدادات فيرفوكس فى المنزل ستجده فى هذا المسار
                          كود PHP:
                          /home/$USERNAME/.mozilla 
                          وقم بحزفه ثم تشغيل فيرفوكس
                          كود:
                          [[email protected] ~]$ /home/$USERNAME/.mozilla
                          bash: /home/ahmed/.mozilla: is a directory
                          [[email protected] ~]$
                          كيف اصل للدليل

                          تعليق


                          • #15
                            المشاركة الأصلية بواسطة (اﻹحساس) مشاهدة المشاركة
                            كود:
                            [[email protected] ~]$ /home/$USERNAME/.mozilla
                            bash: /home/ahmed/.mozilla: is a directory
                            [ahme[email protected] ~]$
                            كيف اصل للدليل
                            مخفى فى المنزل إضغط ctrl+h وإبحث عنه
                            صحيح يجب إغلاق فيرفوكس قبل كل عمل تقوم به نهائيا ثم فتحه من جديد

                            تعليق

                            يعمل...
                            X