إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

مشكلة بالـdependency بالديبيان .

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • مشكلة بالـdependency بالديبيان .

    سلام عليكم ...

    بعد مانزلت الديبيان وارتحت وضبطت الجهاز بقي تنزيل الـcompiz fusion لكن طلعت لي مشكلة غريب

    رحت للترمينال وكتبت :

    كود:
    debian:/home/snix# apt-get install  compiz-fusion-all
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      compiz-fusion-all: Depends: compiz-core (>= 0.5.1) but it is not going to be i nstalled
                         Depends: compiz-plugins (>= 0.5.1) but it is not going to b e installed
                         Depends: compiz (>= 0.5.1) but it is not going to be instal led
                         Depends: compiz-gnome (>= 0.5.1) but it is not going to be installed
                         Depends: compiz-kde (>= 0.5.1) but it is not going to be in stalled
                         Depends: libdecoration0 (>= 0.5.1) but it is not going to b e installed
                         Depends: libdecoration0-dev (>= 0.5.1) but it is not going to be installed
                         Depends: libcompizconfig0 but it is not going to be install ed
                         Depends: libcompizconfig0-dev but it is not going to be ins talled
                         Depends: compizconfig-backend-gconf but it is not going to be installed
                         Depends: compizconfig-backend-kconfig but it is not going t o be installed
                         Depends: compizconfig-python but it is not going to be inst alled
                         Depends: ccsm but it is not going to be installed
                         Depends: compiz-fusion-plugins-main but it is not going to be installed
                         Depends: compiz-fusion-plugins-extra but it is not going to  be installed
                         Depends: compiz-fusion-plugins-unsupported but it is not go ing to be installed
                         Depends: emerald (>= 0.3.0+git20070728) but it is not going  to be installed
                         Depends: libemeraldengine0 (>= 0.3.0+git20070728) but it is  not going to be installed
                         Depends: libemeraldengine-dev (>= 0.3.0+git20070728) but it  is not going to be installed
                         Depends: emerald-themes (>= 0.3.0+git20070728) but it is no t going to be installed
                         Depends: fusion-icon but it is not going to be installed
                         Depends: compiz-fusion-plugins-unstable but it is not going  to be installed
    E: Broken packages

    مشكلة كبيره .. هالملفات مانزلها ؟؟ حاولت انزلها لكن طلعت لي مشكلة قريبه من اللي فوق ... حاولت انزل الـcompiz core من الباكيجات بالاعلى :

    كود:
    debian:/home/snix# apt-get install compiz-core
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      compiz-core: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is to be installe d
                   Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is to be installed
                   Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is to be installed
                   Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is to be install ed
    E: Broken packages
    وماني قادر انزل لي شي !!! كل مااحاول انزل حاجه ماقدرت ... نفس المشكله عن طريق الـsynaptic package manager


    وايضا ً حاولت بالامرaptitude ومانفع شي :

    كود:
    debian:/home/snix# aptitude install compiz-fusion-all
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Writing extended state information... Done
    Reading task descriptions... Done
    Building tag database... Done
    The following packages are BROKEN:
      compiz-core compiz-fusion-plugins-extra compiz-fusion-plugins-main
      compiz-fusion-plugins-unstable compiz-fusion-plugins-unsupported
      compiz-gnome compiz-kde compiz-plugins compizconfig-backend-gconf
      compizconfig-backend-kconfig compizconfig-python emerald libcompizconfig0
      libdecoration0 libemeraldengine0
    The following NEW packages will be automatically installed:
      ccsm compiz compiz-bcop compiz-dev compiz-fusion-extras emerald-themes
      freeglut3 fusion-icon libcompizconfig0-dev libdbus-qt-1-1c2
      libdecoration0-dev libemeraldengine-dev libgl1-mesa-dev libice-dev
      libpng12-dev libsm-dev libstartup-notification0-dev libx11-dev libxau-dev
      libxcomposite-dev libxcomposite1 libxcursor-dev libxdamage-dev
      libxdmcp-dev libxext-dev libxfixes-dev libxinerama-dev libxrandr-dev
      libxrender-dev mesa-common-dev mesa-utils pkg-config python-ctypes
      x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
      x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev
      x11proto-render-dev x11proto-xext-dev x11proto-xinerama-dev xtrans-dev
      zlib1g-dev
    The following NEW packages will be installed:
      ccsm compiz compiz-bcop compiz-dev compiz-fusion-all compiz-fusion-extras
      emerald-themes freeglut3 fusion-icon libcompizconfig0-dev
      libdbus-qt-1-1c2 libdecoration0-dev libemeraldengine-dev libgl1-mesa-dev
      libice-dev libpng12-dev libsm-dev libstartup-notification0-dev libx11-dev
      libxau-dev libxcomposite-dev libxcomposite1 libxcursor-dev libxdamage-dev
      libxdmcp-dev libxext-dev libxfixes-dev libxinerama-dev libxrandr-dev
      libxrender-dev mesa-common-dev mesa-utils pkg-config python-ctypes
      x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
      x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev
      x11proto-render-dev x11proto-xext-dev x11proto-xinerama-dev xtrans-dev
      zlib1g-dev
    0 packages upgraded, 61 newly installed, 0 to remove and 0 not upgraded.
    Need to get 13.3MB of archives. After unpacking 30.8MB will be used.
    The following packages have unmet dependencies:
      libcompizconfig0: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed .
                        Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is installed.
      compiz-kde: Depends: kdelibs4c2a (>= 4:3.5.7-1) but 4:3.5.5a.dfsg.1-8 is insta lled.
                  Depends: kwin (>= 4:3.5.7-1) but it is not installable
                  Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
                  Depends: libdbus-1-3 (>= 1.1.1) but 1.0.2-1 is installed.
                  Depends: libgcc1 (>= 1:4.2-20070516) but 1:4.1.1-21 is installed.
                  Depends: libstdc++6 (>= 4.2-20070516) but 4.1.1-21 is installed.
                  Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is installed.
      libdecoration0: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
      compizconfig-backend-gconf: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is  installed.
                                  Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is installed.
                                  Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is i nstalled.
                                  Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is installed.
                                  Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 i s installed.
      compiz-fusion-plugins-unstable: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch 2 is installed.
                                      Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is i nstalled.
                                      Depends: libgcc1 (>= 1:4.2-20070516) but 1:4.1 .1-21 is installed.
                                      Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2  is installed.
                                      Depends: libstdc++6 (>= 4.2-20070516) but 4.1. 1-21 is installed.
                                      Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is installed.
                                      Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1  is installed.
                                      Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2 -5 is installed.
      compiz-plugins: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
                      Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is installed.
                      Depends: libdbus-1-3 (>= 1.1.1) but 1.0.2-1 is installed.
                      Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is installed.
                      Depends: libgtk2.0-0 (>= 2.10.12-3) but 2.8.20-7 is installed.
                      Depends: librsvg2-2 (>= 2.16.1) but 2.14.4-3 is installed.
                      Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is installed.
      compizconfig-python: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is instal led.
                           Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is install ed.
                           Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is installe d.
                           Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is install ed.
                           Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is insta lled.
      compizconfig-backend-kconfig: Depends: kdelibs4c2a (>= 4:3.5.7-1) but 4:3.5.5a .dfsg.1-8 is installed.
                                    Depends: libart-2.0-2 (>= 2.3.18) but 2.3.17-1 i s installed.
                                    Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
                                    Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etc h1 is installed.
                                    Depends: libgcc1 (>= 1:4.2-20070516) but 1:4.1.1 -21 is installed.
                                    Depends: libstdc++6 (>= 4.2-20070516) but 4.1.1- 21 is installed.
                                    Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is  installed.
                                    Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 i s installed.
                                    Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5  is installed.
                                    Depends: zlib1g (>= 1:1.2.3.3.dfsg-1) but 1:1.2. 3-13 is installed.
      emerald: Depends: libatk1.0-0 (>= 1.13.2) but 1.12.4-3 is installed.
               Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
               Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is installed.
               Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is installed.
               Depends: libgtk2.0-0 (>= 2.10.12-3) but 2.8.20-7 is installed.
               Depends: libpango1.0-0 (>= 1.16.5) but 1.14.8-5 is installed.
               Depends: libwnck18 (>= 2.18.2) but 2.14.3-1 is installed.
               Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is installed.
      compiz-fusion-plugins-extra: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 i s installed.
                                   Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is inst alled.
                                   Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is  installed.
                                   Depends: libpango1.0-0 (>= 1.16.5) but 1.14.8-5 i s installed.
                                   Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is installed.
                                   Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is  installed.
                                   Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is installed.
      libemeraldengine0: Depends: libatk1.0-0 (>= 1.13.2) but 1.12.4-3 is installed.
                         Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installe d.
                         Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is installed.
                         Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is installed .
                         Depends: libgtk2.0-0 (>= 2.10.12-3) but 2.8.20-7 is install ed.
                         Depends: libpango1.0-0 (>= 1.16.5) but 1.14.8-5 is installe d.
                         Depends: libwnck18 (>= 2.18.2) but 2.14.3-1 is installed.
                         Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is install ed.
      compiz-fusion-plugins-unsupported: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13e tch2 is installed.
                                         Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3 -3 is installed.
                                         Depends: libxml2 (>= 2.6.29) but 2.6.27.dfs g-1 is installed.
                                         Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1. 0.2-5 is installed.
      compiz-core: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
                   Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is installed.
                   Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is installed.
                   Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is installed.
      compiz-fusion-plugins-main: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is  installed.
                                  Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is insta lled.
                                  Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is installed.
                                  Depends: libpango1.0-0 (>= 1.16.5) but 1.14.8-5 is  installed.
                                  Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is i nstalled.
                                  Depends: libxml2 (>= 2.6.29) but 2.6.27.dfsg-1 is installed.
                                  Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 i s installed.
      compiz-gnome: Depends: libart-2.0-2 (>= 2.3.18) but 2.3.17-1 is installed.
                    Depends: libatk1.0-0 (>= 1.13.2) but 1.12.4-3 is installed.
                    Depends: libbonobo2-0 (>= 2.15.0) but 2.14.0-3 is installed.
                    Depends: libbonoboui2-0 (>= 2.15.1) but 2.14.0-5 is installed.
                    Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is installed.
                    Depends: libcairo2 (>= 1.4.0) but 1.2.4-4 is installed.
                    Depends: libdbus-1-3 (>= 1.1.1) but 1.0.2-1 is installed.
                    Depends: libdbus-glib-1-2 (>= 0.74) but 0.71-3 is installed.
                    Depends: libglib2.0-0 (>= 2.12.9) but 2.12.4-2 is installed.
                    Depends: libgnome-keyring0 (>= 0.8) but 0.6.0-3 is installed.
                    Depends: libgnome2-0 (>= 2.17.3) but 2.16.0-2 is installed.
                    Depends: libgnomeui-0 (>= 2.17.1) but 2.14.1-2 is installed.
                    Depends: libgnomevfs2-0 (>= 1:2.17.90) but 1:2.14.2-7 is install ed.
                    Depends: libgtk2.0-0 (>= 2.10.12-3) but 2.8.20-7 is installed.
                    Depends: libpango1.0-0 (>= 1.16.5) but 1.14.8-5 is installed.
                    Depends: libwnck18 (>= 2.18.2) but 2.14.3-1 is installed.
                    Depends: libxrandr2 (>= 2:1.2.0) but 2:1.1.0.2-5 is installed.
    Resolving dependencies...
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    ccsm [Not Installed]
    compiz [Not Installed]
    compiz-core [Not Installed]
    compiz-fusion-all [Not Installed]
    compiz-fusion-plugins-extra [Not Installed]
    compiz-fusion-plugins-main [Not Installed]
    compiz-fusion-plugins-unstable [Not Installed]
    compiz-fusion-plugins-unsupported [Not Installed]
    compiz-gnome [Not Installed]
    compiz-kde [Not Installed]
    compiz-plugins [Not Installed]
    compizconfig-backend-gconf [Not Installed]
    compizconfig-backend-kconfig [Not Installed]
    compizconfig-python [Not Installed]
    emerald [Not Installed]
    emerald-themes [Not Installed]
    fusion-icon [Not Installed]
    libcompizconfig0 [Not Installed]
    libcompizconfig0-dev [Not Installed]
    libdecoration0 [Not Installed]
    libdecoration0-dev [Not Installed]
    libemeraldengine-dev [Not Installed]
    libemeraldengine0 [Not Installed]
    
    Score is -9803
    
    Accept this solution? [Y/n/q/?] y
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Do you want to continue? [Y/n/?] y
    Writing extended state information... Done
    debian:/home/snix#
    احس ان فيه باكيج واقف لي وماادري فينه مشكله غريبه ..
    Macbook Air: OS X 10.9.2 + Kali Linux 1.0.6

  • #2
    الحزم اللي تحاول انك تثبتهم مازالو في طور testing و unstable.

    الحل قم باضافة مصادر ديبيان ل testing و unstable وستنتهي المشكله باذن الله.

    ملاحضه : المشاكل التي ستحدث من جراء تركيب هذه الحزم هي مسؤليتك انت وحدك فكن حذر.

    تعليق


    • #3
      الحزم اللي تحاول انك تثبتهم مازالو في طور testing و unstable.

      الحل قم باضافة مصادر ديبيان ل testing و unstable وستنتهي المشكله باذن الله.
      المصادر هذا تبع ايش ؟؟ انا اضفت مصادر للكومبيز فقط .. بحثت لكن مالقيت شي يمكن لاني ماادري ابحث عن ايش بالضبط .

      لو عندك المصادر ياليت ماتبخل علينا !َ


      ملاحضه : المشاكل التي ستحدث من جراء تركيب هذه الحزم هي مسؤليتك انت وحدك فكن حذر.
      بالتأكيد ..
      Macbook Air: OS X 10.9.2 + Kali Linux 1.0.6

      تعليق


      • #4
        هذي مصادر:
        كود:
        deb http://ftp.debian.org/debian/ unstable main
        deb-src http://ftp.debian.org/debian/ unstable main
        
        deb http://ftp.debian.org/debian/ testing main
        deb-src http://ftp.debian.org/debian/ testing main
        
        deb http://security.debian.org/ testing/updates main
        deb-src http://security.debian.org/ testing/updates main
        ولازم تضيف لهذا الملف
        كود:
        /etc/apt/preferences
        التالي:
        كود:
        cat /etc/apt/preferences
        Package: *
        Pin: release o=Debian,a=testing
        Pin-Priority: 900
        
        Package: *
        Pin: release o=Debian,a=unstable
        Pin-Priority: 300
        وكذلك هذا الملف
        كود:
        /etc/apt/apt.conf
        التالي:
        كود:
        APT::Default-Release  testing;
        وهذا الرابط يمكن يفيدك http://forums.debian.net/viewtopic.php?t=15612

        وفيه طريقه يمكن تنجح
        كود:
        apt-get install YourPackage -t unstable
        وفيه بالمرفقات كتيب عن apt اقرا عن الـ unstable
        *ملاحظه: خلفية الكتيب راح تعجب ذوقك.

        وفي الاخير اتمنى ان اكون غطيت تساؤلاتك.....
        التعديل الأخير تم بواسطة Genio; الساعة 11-07-2008, 07:31 AM.

        تعليق


        • #5
          شاكر لك اخوي .. راح احل مشكلة اخرى بالجهاز عندي وبعدها اجرب .. شاكر لك مره آخرى .
          Macbook Air: OS X 10.9.2 + Kali Linux 1.0.6

          تعليق


          • #6
            اقول ابعد عن السلحفاة ديبيان ، وخلك على Mint بس، دبيان ماوراها الا وجع الراس.

            تعليق


            • #7
              اقول ابعد عن السلحفاة ديبيان ، وخلك على Mint بس، دبيان ماوراها الا وجع الراس.
              هههههههههه لسا راح ابدا بوجع الراس .. انا نزلت عندي التوزيعتين كلهم .. واشوف اخرتها مع الديبيان .
              Macbook Air: OS X 10.9.2 + Kali Linux 1.0.6

              تعليق


              • #8
                وفيه بالمرفقات كتيب عن apt اقرا عن الـ unstable
                *ملاحظه: خلفية الكتيب راح تعجب ذوقك.

                وفي الاخير اتمنى ان اكون غطيت تساؤلاتك.....[/QUOTE]

                شكرا على الكتيب المفيد
                براءة:
                إن سطام لا يضمن صحة و لا دقة ما يكتب ، بل هو إلى الخطأ أقرب منه للصواب ، فدقق و لا تسلّم .
                @ksatux

                تعليق


                • #9
                  المشاركة الأصلية بواسطة snix مشاهدة المشاركة
                  هههههههههه لسا راح ابدا بوجع الراس .. انا نزلت عندي التوزيعتين كلهم .. واشوف اخرتها مع الديبيان .
                  بس صدقني وجع الراس هذا بيجيبلك فايده، اكثر توزيعه تعلمت منها واستفدت هي ديبيان.
                  بالتوفيق ان شاء الله.

                  المشاركة الأصلية بواسطة طحطوح مشاهدة المشاركة

                  شكرا على الكتيب المفيد
                  العفو، اهم شي انك استفدت.

                  تعليق


                  • #10
                    كيفكم أنا صارت عندي لمشكلة وحليت هذه المشكلة بعمل أب ديت للنسخة كاملة ، من Adminstration > Update manager
                    وم ثم ضغطت على Update للنسخة من 9.10 الى 10.4 ، وانحلت المشكلة . بنجاح

                    تعليق

                    يعمل...
                    X