إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

مشكلة في تثبيت الدرايفر ndiswrapper للـ wifi

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • مشكلة في تثبيت الدرايفر ndiswrapper للـ wifi

    السلام عليكم ،،،،
    عندي ZenWalk و كارت ويفي ،

    http://www.zenwalk.org/

    حاولت تثبيت الدرايفر ndiswrapper ، -و الذي يدعم الكارت ويفي التي عندي- المشكلة التي واجهتني أثناء التثبيت :
    عملية التثبيت تتطلب و جود الـ kernel source --- و قمت بتثبيت حزمة kernel header من السي دي
    و تتطلب أيضا و جود link في source kernel folder إلى modules directory
    و لكن هنا واجهتني المشكلة :
    كود:
    root[ndiswrapper-1.40rc1]# ls
    AUTHORS  ChangeLog  INSTALL  Makefile  README  driver  loadndisdriver.8  ndiswrapper.8  ndiswrapper.spec  utils
    
    root[ndiswrapper-1.40rc1]# ln -s /usr/include/linux/  /lib/modules/2.6.18.6/build
    
    root[ndiswrapper-1.40rc1]# make
    make: AVERTISSEMENT: fichier « Makefile » a une date de modification 5,4e+06 dans le futur
    make -C driver
    make[1]: entrant dans le répertoire « /root/linux wifi 2/ndiswrapper-1.40rc1/ndiswrapper-1.40rc1/driver »
    make[1]: AVERTISSEMENT: fichier « Makefile » a une date de modification 5,4e+06 dans le futur
    Can't find kernel build files in /lib/modules/2.6.18.6/build;
      give the path to kernel build directory with 
      KBUILD=<path> argument to make
    make[1]: *** [prereq_check] Erreur 1
    make[1]: quittant le répertoire « /root/linux wifi 2/ndiswrapper-1.40rc1/ndiswrapper-1.40rc1/driver »
    make: *** [all] Erreur 2
    حيث أني لم أعرف بالضبط كبف أقوم باللينك ،،،، أرجو المساعدة في هذا الموضوع ، وهذا جزء من ملف المساعدة الخاص بالدرايفر
    http://ndiswrapper.sourceforge.net/m...p/Installation
    كود:
    --------------
    Prerequisites
    
    You need a recent kernel at least 2.6.6 or 2.4.26 with source. Under Red Hat or Mandrake, the sources can be installed using the package kernel-source<kernel-version>.rpm command. Under Ubuntu use the sudo apt-get install linux-headers-`uname -r` command. Make sure there is a link to the kernel source from the modules directory. /lib/modules/VERSION/build should be a link to the kernel source, where VERSION is the version of the kernel you are running. If there is no link, you'll get an error at the make install step. To create a link, assuming the kernel sources are present, use the command
    
    
    ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build
    
    Under Ubuntu, you also need the build-essential package, use the sudo apt-get install build-essential command.
    
    Make sure you have started compiling the kernel sources, so needed header files are present. Some vendors ship ndiswrapper in their distributions. Either use it or make sure you remove it before installing ndiswrapper by yourself. Make sure you have the Wireless Tools installed. Again, there is a package that comes along with Red Hat and Mandrake distributions. If you are using Debian you can install the wireless-tools package from the mirror, here.
    سبب ضياع العباد أنهم مسلمون بالوراثة ــ هل فكرت في علة خلقك؟
    Working on Google soc 2010 - Auto parallelization in GCC

  • #2
    انا معي سلاكس وماشي التثبيت بدون kernel source
    فخذها جاهزة لتوزيعتك بدل ماتبنيها
    ubuntu suse-fedora
    ولو كان اسم واجهة الكرت wlan0 يكون هذا طريقة التعريف
    خذ الملفين اللي امتدادهم *.inf, *.sys ونسخهم لمجلد عندك مثلا home
    كود:
    ndiswrapper -i /home/file.inf
    ndiswrapper -m
    modprobe ndiswrapper
    ifconfig wlan0 up
    dhcpd wlan0
    ثم شغل kwifimanager واضبط اسم الشبكة essid والرقم السري اذا موجود وغيرها

    تعليق


    • #3
      شكرا أخي ، dark2x3d
      خذها جاهزة لتوزيعتك بدل أن تبنيها ،،، نعم أخي ،،، و لكن لي سؤال قد يبدو سخيف ،،، هل كل الملفات rpm تكون جاهزة دون أن تحتاج إلى السورس أم هناك منها ما يحتاج إلى السورس لأني في مرة من المرات قمت بتثبيت ملف rpm و لكنه فثل لأنه لم يجد إحدى المكتبات ،،،
      طبعا ستقول لي جرب الملفات الموجودة في الموقعين ،،، و لكن المشكلة أن الجهاز الذي أريد أن أثبت عليه الدرايفر في الجامعة و لا بمكنني إستعماله إلا مرة في الأسبوع ،،،،
      سبب ضياع العباد أنهم مسلمون بالوراثة ــ هل فكرت في علة خلقك؟
      Working on Google soc 2010 - Auto parallelization in GCC

      تعليق


      • #4
        في منها جاهز وهو ينتهي بامتداد
        program.rpm
        ومنها مصدري يحتاج لبناء وينتهي با&#251;متداد
        program.src.rpm
        ----------------------------------------------
        طبعا على حسب التوزيعة اللي بتثبت عليها اذا كانت جميع المكتبات متوفرة مابتحتاج شي ولما تكون ناقصة يبغالك تحمل وتثبت الناقص من هنا http://rpm.pbone.net

        تعليق


        • #5
          بارك الله فيك على الإجابة السريعة ،،
          سأجربها حالا ،،،،
          سبب ضياع العباد أنهم مسلمون بالوراثة ــ هل فكرت في علة خلقك؟
          Working on Google soc 2010 - Auto parallelization in GCC

          تعليق


          • #6
            ولكن ما هو أمر تثبيت rpm على السلاكوير
            لأن الأمر rpm لا يوجد
            سبب ضياع العباد أنهم مسلمون بالوراثة ــ هل فكرت في علة خلقك؟
            Working on Google soc 2010 - Auto parallelization in GCC

            تعليق


            • #7
              خذ هذي لسلاكوير وثبت المناسبة لتوزيعتك واصدار الkernel
              http://www.linuxpackages.net/search_...iswrapper&ver=
              كود:
              installpkg ndiswrapper-*****.tgz

              تعليق

              يعمل...
              X