إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

python(abi

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [تم حل المشكلة] python(abi


    السلام عليكم يا شباب ....عندي حزمة أكتر من برنامج بالفيدورا بعتمد عليها متل ال mpich2 و ال compiz fusion إسمها

    python(abi)
    هذا الإسم الذي يضعه مدير الحزم أثناء دراسة الإعتماديات و قد بحثت عنها ولم أجدها


    هل مدير الحزم يحدد بالضبط إسم الحزمة أم من الممكن ان تكون هذه الحزمة ضمن حزمة أكبر منها و إسمها مختلف عن ذلك...

  • #2
    بسم الله الرحمن الرحيم

    1
    2

    اضنها abiword

    تعليق


    • #3
      قمت بتركيب libabiword ولا زالت المشكلة قائمة أي أنها ليست هذه الحزمة ...و أيضا الحزمتان السابقتان.هل يطلب مدير الحزم مني تركيب الحزمة

      python أي نواة لغة البرمجة بايثون ...؟؟؟

      تعليق


      • #4
        اكتب فى الطرفية
        كود PHP:
        rpm ---provides python grep abi 
        سيكون الناتج هو اصدار الحزمة لديك قارن بينها وبين الإصدار المطلوب عن طريق
        كود PHP:
        rpm -qp --requires PACKAGENAME 
        استبدل PACKAGENAME باسم الحزمة

        تعليق


        • #5


          القصة أنني أريد تركيب mpich2 ووضعت كل الحزم التي تعتمد عليها في ملف اسمه mpi ثم من الطرفية

          cd mpi
          sudo rpm -ivh *.rpm


          ومدير الحزم يطبع لي الرسالة التالية :

          file /lib/libz.so.1 from install of zlib-1.2.5-2.fc14.i686 conflicts with file from package zlib-1.2.3-23.fc12.i686
          file /usr/bin/pydoc from install of python-2.7-8.fc14.3.i686 conflicts with file from package python-2.6.4-25.fc13.i686
          file /usr/bin/python from install of python-2.7-8.fc14.3.i686 conflicts with file from package python-2.6.4-25.fc13.i686



          حيث يحتوي المجلد mpi على الحزم python-2.7-8.fc14.3.i686 و الحزمة zlib-1.2.5-2.fc14 وهي الحزم التي

          إحتاجها مدير الحزم عند دراسة الإعتماديات ..فإنتقلت المشكلة من حالة الإعتماديات إلى حالة ال conflict .

          وقد خطر لي أن المشكلة يمكن أن تحل بحذف الحزمة python-2.6.4-25.fc13.i686 وقد حاولت حذفها من مدير الحزم

          لكن رفض بسبب أن هناك حزم أخرى تعتمد عليها ..أرجوكم ما هو الحل...؟ هل تركيب mpich2 على فيدورا13 مستحيل.....

          تعليق


          • #6
            هل حربت مدير الحزم ؟
            كود PHP:
            yum install mpich2 

            تعليق


            • #7
              شكرا أستاذ إيهاب على إصغائك ..ومتابعتك ...في الحقيقة ..أنا لم أجرب مدير الحزم yum بسبب أن الإتصال بالنت متعذر عندي

              على الرغم من أنني قمت بتركيب تعريف للمودوم .لسبب لا أعرفه....لكن على كل الأحوال أنا بحاجة إلى الحزم الفعلية ..لأني سأقوم

              بتركيبها في مخبر الكلية حيث إنه لا يوجد إتصال بالنت ...

              هل مشكلة conflict لا يمكن حلها أو معالجتها.....؟؟؟؟؟

              تعليق


              • #8
                يمكن تنفيذ هذا الأمر على فيدورا 13 متصل بالنت
                كود PHP:
                yumdownloader --urls --resolve mpich2 
                قم بتحميل الروابط الناتجة وتوجه لتثبيتها على الجهاز الغير متصل

                آسف لا أعمل على فيدورا حاليا

                تعليق


                • #9
                  و أخيرا تم حل المشكلة بتطبيق الأمر التالي :

                  yumdownloader --urls --resolve mpich2


                  سينتج الرابطان التاليان اللذان سنحمل منهما الحزمة التي تم تصحيحها من قبل الريدهات :

                  http://mirror.bytemark.co.uk/fedora/....fc13.i686.rpm


                  والرابط الثاني هو :
                  http://mirror.bytemark.co.uk/fedora/linux/releases/13/Everything/i386/os//Packages/environment-modules-3.2.7b-7.fc13.i686.rpm

                  وسيتم تركيب mpich2 بنجاح ..

                  تعليق

                  يعمل...
                  X