إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

مشكلة مع eclipse

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [مشكلة] مشكلة مع eclipse

    السلام عليكم :
    اعمل على فيدورا 13 والنسخة الافتراضية الموجودة من برنامج eclipse فيها
    عند تنفيذ كود بالجافا يظهر لي الخطأ
    كود PHP:
    Exception in thread "main" java.lang.ErrorUnresolved compilation problem
    بحثت عن هذه المشكلة ووجدت مواضيع عن هذه المشكلة لكني لم اجد الحل الوافي ؟؟؟

    هل يمكن لاحد مساعدتي وماهي المشكلة بالضبط ؟؟

    يمكن الاستفادة من هذه المخرجات ايضاً

    كود PHP:
    [viyan@viyan ~]$ java -version
    java version 
    "1.6.0_17"
    OpenJDK Runtime Environment (IcedTea6 1.7.1) (fedora-37.b17.fc13-i386)
    OpenJDK Client VM (build 14.0-b16mixed mode)
     
    [
    viyan@viyan ~]$ javac -version
    javac 1.6.0_17 
    شكراً

  • #2
    تم النقل للقسم المناسب .

    تعليق


    • #3
      استبدل الجافا الحرة بجافا سن
      كود PHP:
      update-alternatives --config java 

      تعليق


      • #4
        السلام عليكم :
        شكراً لكم على الردود
        بالنسبة للخطأ كان من الكود ولم يكن من البرنامج

        لو سمحتم لدي سؤال وأرجو أن تساعدوني

        أريد إضافة plugins إلى eclipse
        واللي هي الاضافة JProbe Plugins for Eclipse
        عندما قمت بفك ضغطه في المجلد الخاص ب eclipse لكن ليس
        الموجود مع فيدورا وإنما نسخة أخرى protable
        مشي الحال وطلع عندي زر Jprobe في eclipse
        لكنه لم يعمل للسبب التالي
        please check the JRE version you used to launch Eclipse. You must use a Java 1.6 JRE to run the JProbe plugins for Eclipse.

        في المشاركة الاولى من هذا الموضوع واضح أن الجافا الموجودة عندي هي 1.6

        عندما قمت بإضافة نفس الاضافة JProbe Plugins for Eclipse إلى ال Eclipse الموجودة افتراضياً إلى المسار
        /usr/lib/eclipse/plugins



        كود PHP:
        [root@viyan viyan]# cp '/home/viyan/JProbe Plugins for Eclipse'  '/usr/lib/eclipse/plugins'  
        cpomitting directory `/home/viyan/JProbe Plugins for Eclipse' 
        ما الحل وكيف أقوم بإضافة هذه الاضافة ؟؟
        علماً أنه لم ينفع الخيار الموجود في eclipse
        help -> install new software

        وشكراً ....

        تعليق


        • #5
          أعتقد أنه يقصد نسخة sun من جافا وليس openjdk في رسالة الخطأ
          لنسخ مجلد إستخدم cp -R

          تعليق


          • #6
            المشاركة الأصلية بواسطة أمين روخ مشاهدة المشاركة
            أعتقد أنه يقصد نسخة sun من جافا وليس openjdk في رسالة الخطأ
            لنسخ مجلد إستخدم cp -R
            شكراً لك على الرد
            لكن ما الفرق بين sun من جافا و openjdk ؟؟
            والفرق بين الجافا الحرة والجافا من sun ??
            إذا ممكن طبعاً..
            عندما نسخت المجلد أصبح من النوع unreadable؟؟
            ماذا أفعل ؟؟
            وشكراً

            تعليق


            • #7
              المشاركة الأصلية بواسطة viyan مشاهدة المشاركة
              شكراً لك على الرد
              لكن ما الفرق بين sun من جافا و openjdk ؟؟
              والفرق بين الجافا الحرة والجافا من sun ??
              إذا ممكن طبعاً..
              عندما نسخت المجلد أصبح من النوع unreadable؟؟
              ماذا أفعل ؟؟
              وشكراً
              الأولى تحتوي أجزاء غير حرة بينما الثانية فلا
              أعتقد لن تعمل الإضافة حتى بعد نقلها وستظهر نفس رسالة الخطأ الأولى

              تعليق

              يعمل...
              X