إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

مستودعات اعجوبه 4 في فيدورا 14

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • ابن عبد البر
    رد
    جزاك الله خيرا يا أخي على مساعدتك . في الحقيقة إستعملت أقصر طريق و هو تنصيب أعجوبة التي كانت بدايتي معها .
    نقلك فؤادك حيث شئت من الهوى
    فما الحب إلا للحبيب الأول - أعجوبة في حالتي -
    وكم من منزل يسكنه الفتى - و أنا أقول : كم من نظام ينصبه الفتى -
    ويبقى حنينه دوما للمنزل الأول

    اترك تعليق:

  • محمد شعبان
    ::مشرف قسم توزيعة أعجوبة::

  • محمد شعبان
    رد
    وتيسيرا عليك قم بفتح الطرفية (terminal) وطبق هذه الخطوات
    سنقوم بتثبيت بعض الحزم بصلاحيات المستخدم الجذر
    كود PHP:
    su -
    yum -y install rpm-build gcc python perl gettext python-setuptools
    exit 
    سنقوم بتنزيل الحزم وبنائها بصلاحيات المستخدم العادي
    كود PHP:
    wget http://www.ojuba.org/downloads/releases/4/Everything/source/SRPMS/thawab-3.0.8-1.oj4.src.rpm http://www.ojuba.org/downloads/releases/4/Everything/source/SRPMS/othman-0.2.5-1.oj4.src.rpm http://www.ojuba.org/downloads/releases/4/Everything/source/SRPMS/monajat-2.3.2-1.oj4.src.rpm http://www.ojuba.org/downloads/releases/4/Everything/source/SRPMS/hijra-0.1.18-1.oj4.src.rpm
    mkdir -~/rpmbuild/{BUILD,BUILDROOT,RPMS,SOURCES,SPECS,SRPMS}
    echo 
    '%_topdir %(echo $HOME)/rpmbuild' > ~/.rpmmacros
    rpmbuild 
    --rebuild *.src.rpm
    rm 
    -rf *.src.rpm 
    سنقوم بتثبيت الحزم بصلاحيات المستخدم الجذر
    كود PHP:
    su -
    rpm -/home/username/rpmbuild/RPMS/noarch/*.src.rpm
    exit 
    الحزم الجديدة تجدها في هذا المسار
    كود PHP:
    /home/username/rpmbuild/RPMS/noarch
    قم بتغيير username الي اسم المستخدم الخاص بك
    دمتم بود
    محمد شعبان
    ::مشرف قسم توزيعة أعجوبة::
    التعديل الأخير تم بواسطة محمد شعبان; الساعة 10-02-2011, 01:41 PM.

    اترك تعليق:

  • محمد شعبان
    ::مشرف قسم توزيعة أعجوبة::

  • محمد شعبان
    رد
    المشاركة الأصلية بواسطة ابن عبد البر مشاهدة المشاركة
    جزاك الله خيرا .
    أرجو أن يتسع صدرك لجهلي , لكنني لم افهم شيئا ؟
    لا عليك اخي الكريم كلنا هنا طلاب علم
    هل قرات هذا الموضوع إنشاء حزم RPM
    فأستاذ مؤيد قام بشرح تفصيلي للموضوع
    ارجو توضيح ما الذي لم تفهمه بالضبط وما هي المحاولات التي قمت بها
    دمتم بود

    اترك تعليق:


  • ابن عبد البر
    رد
    المشاركة الأصلية بواسطة محمد شعبان مشاهدة المشاركة
    انظر رد الاستاذ مؤيد


    استخدم الاوامر بصلاحيات المستخدم العادي
    وعند التثبيت استخدم الرووت مع اضافه --skip-broken
    كود PHP:
    yum ---skip-broken install ~/path/packagename.rpm 
    للمزيد من المعلومات
    إنشاء حزم RPM

    دمتم بود
    جزاك الله خيرا .
    أرجو أن يتسع صدرك لجهلي , لكنني لم افهم شيئا ؟

    اترك تعليق:

  • محمد شعبان
    ::مشرف قسم توزيعة أعجوبة::

  • محمد شعبان
    رد
    المشاركة الأصلية بواسطة ابن عبد البر مشاهدة المشاركة
    شكرا جزيلا أستاذ مؤيد على الرد . لكنني لم أفهم هذه الكلمة التي في إقتباسك بالأحمر , أيضا أين يمكن أن أجد src.rpm.
    انظر رد الاستاذ مؤيد
    المشاركة الأصلية بواسطة alsadi مشاهدة المشاركة
    فضلا بعض إضافة مستودعات أعجوبة تأكد من تعطيلها جميعها
    كود:
    enabled=0
    وعندما تريدها فعلها
    كود:
    yum install --enable-repos=ojuba,ojuba-updates XYZ
    بسبب اختلاف إصدار بايثون من 2.6.x إلى 2.7.x
    عليك تنزيل ملفات .src.rpm
    yumdownloader --enable-repos=ojuba,ojuba-updates --source thawab
    rpmbuild --rebuild thawab-XYZ.src.rpm

    ثم تنزيل الملف الناتج
    استخدم الاوامر بصلاحيات المستخدم العادي
    وعند التثبيت استخدم الرووت مع اضافه --skip-broken
    كود PHP:
    yum ---skip-broken install ~/path/packagename.rpm 
    للمزيد من المعلومات
    إنشاء حزم RPM

    دمتم بود

    اترك تعليق:


  • ابن عبد البر
    رد
    المشاركة الأصلية بواسطة alsadi مشاهدة المشاركة
    بالنسبة لحزم بايثون عليكم تصنيفها من المصدر لأن f14 تستعمل بايثون 2.7 وليس 2.6

    الأمر ليس صعبا

    تضر ملف .src.rpm وبصلاحيات المستخدم العادي اكتب
    rpmbuild --rebuild foo.src.rpm

    وستحصل على الملف الجديد
    شكرا جزيلا أستاذ مؤيد على الرد . لكنني لم أفهم هذه الكلمة التي في إقتباسك بالأحمر , أيضا أين يمكن أن أجد src.rpm.

    اترك تعليق:

  • alsadi
    ::ضيف شرف::
    الأستاذ مؤيد السعدي

  • alsadi
    رد
    بالنسبة لحزم بايثون عليكم تصنيفها من المصدر لأن f14 تستعمل بايثون 2.7 وليس 2.6

    الأمر ليس صعبا

    تضر ملف .src.rpm وبصلاحيات المستخدم العادي اكتب
    rpmbuild --rebuild foo.src.rpm

    وستحصل على الملف الجديد

    اترك تعليق:


  • ابن عبد البر
    رد
    استاذ مؤيد بعد إضافة مستودعات أعجوبة و عند محاولة تثبيت برنامج هجرة أجد هذه الرسالة
    كود:
    Dependency Resolution Errors:
    
    Package: python-othman-0.2.5-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Package: python-whoosh-0.3.18-4.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Package: python-okasha-0.2.0-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Package: thawab-3.0.8-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Dependency Resolution Errors:
    
    Package: hijra-python-0.1.18-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Dependency Resolution Errors:
    
    Package: python-othman-0.2.5-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Package: python-whoosh-0.3.18-4.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Package: python-okasha-0.2.0-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1Package: thawab-3.0.8-1.oj4.noarch (ojuba)
        Requires: python(abi) = 2.6
        Installed: python-2.7-8.fc14.1.i686 (@anaconda-InstallationRepo-201010211814.i386)
            python(abi) = 2.7
        Available: python3-3.1.2-14.fc14.i686 (fedora)
            python(abi) = 3.1

    اترك تعليق:

  • alsadi
    ::ضيف شرف::
    الأستاذ مؤيد السعدي

  • alsadi
    رد
    هل من الممكن اضافه مستودعات اعجوبه 4 بغرض الحصول على تطبيقات اعجوبه مثل ثواب وسواها الى فيدورا 14 وكيف ..؟
    فضلا بعض إضافة مستودعات أعجوبة تأكد من تعطيلها جميعها
    كود:
    enabled=0
    وعندما تريدها فعلها
    كود:
    yum install --enable-repos=ojuba,ojuba-updates XYZ
    بسبب اختلاف إصدار بايثون من 2.6.x إلى 2.7.x
    عليك تنزيل ملفات .src.rpm
    yumdownloader --enable-repos=ojuba,ojuba-updates --source thawab
    rpmbuild --rebuild thawab-XYZ.src.rpm
    ثم تنزيل الملف الناتج

    اترك تعليق:

  • فتحي القدسي
    :: مراقب عام ::

  • فتحي القدسي
    رد
    ساجرب مره اخرى وارد عليك اخي ايهاب

    اترك تعليق:

  • إيهاب الجداوي
    .: إدارة الموقع :.

  • إيهاب الجداوي
    رد
    المستودع يعمل بدون مشاكل
    جرب
    كود PHP:
    yum clean all 

    اترك تعليق:

  • إيهاب الجداوي
    .: إدارة الموقع :.

  • إيهاب الجداوي
    رد
    المشاركة الأصلية بواسطة فتحي القدسي مشاهدة المشاركة
    اخي ايهاب
    هناك خطا عند التحميل من مستودعات السعدي


    هذا مع حزمه ثواب اما بقيه الحزم فقد نجحت في تثبيت اغلبها سارى البقيه
    للعلم هذا المستودع ليس له صلة بالأستاذ مؤيد ولكن كان إختيار الاسم على أساس أن جميع البرامج من عمله وعرفانا بالجميل

    جارى مراجعة المستودع وآسف على الإزعاج
    إيهاب الجداوي
    .: إدارة الموقع :.
    التعديل الأخير تم بواسطة إيهاب الجداوي; الساعة 19-12-2010, 03:28 AM.

    اترك تعليق:

  • فتحي القدسي
    :: مراقب عام ::

  • فتحي القدسي
    رد
    اخي ايهاب
    هناك خطا عند التحميل من مستودعات السعدي
    16:45:43 : YUM: Processing delta metadata
    16:45:43 : YUM: Package(s) data still to download: 2.2 M
    16:46:01 : تنزيل : (1/8): mdbtools-0.6-0.7.cvs20051109.fc12.1.i686.rpm ( 36 k )
    16:46:20 : تنزيل : (2/8): mdbtools-libs-0.6-0.7.cvs20051109.fc12.1.i686.rpm ( 88 k )
    16:46:30 : تنزيل : (3/8): pyparsing-1.5.5-1.fc14.noarch.rpm ( 93 k )
    16:47:01 : WARNING: خطأ في جلب https://sites.google.com/site/ojuba4...c14.noarch.rpm :
    16:47:01 : WARNING: يجري تجربة موقع مرآة آخر.
    16:47:36 : WARNING: خطأ في جلب https://sites.google.com/site/ojuba4...c14.noarch.rpm :
    16:47:36 : WARNING: يجري تجربة موقع مرآة آخر.
    16:48:07 : WARNING: خطأ في جلب https://sites.google.com/site/ojuba4...c14.noarch.rpm :
    16:48:07 : WARNING: يجري تجربة موقع مرآة آخر.
    16:48:33 : تنزيل : (7/8): thawab-3.0.8-2.fc14.noarch.rpm ( 298 k )
    16:49:02 : تنزيل : (8/8): unixODBC-2.2.14-12.fc14.i686.rpm ( 385 k )
    16:49:02 : ERROR: خطأ في عملية yum: [u'Errors were encountered while downloading packages.', 'python-whoosh-0.3.18-4.1.fc14.noarch: failure: python-whoosh-0.3.18-4.1.fc14.noarch.rpm from alsadi: [Errno 256] No more mirrors to try.', 'python-okasha-0.2.0-1.fc14.noarch: failure: python-okasha-0.2.0-1.fc14.noarch.rpm from alsadi: [Errno 256] No more mirrors to try.', 'python-othman-0.2.5-2.fc14.noarch: failure: python-othman-0.2.5-2.fc14.noarch.rpm from alsadi: [Errno 256] No more mirrors to try.']
    هذا مع حزمه ثواب اما بقيه الحزم فقد نجحت في تثبيت اغلبها سارى البقيه

    اترك تعليق:

  • إيهاب الجداوي
    .: إدارة الموقع :.

  • إيهاب الجداوي
    رد
    ألغ هذه المستودعات مؤقتا حتى نرى مايمكن فعله حل المشكلة بدون تضارب حزم

    اترك تعليق:

  • فتحي القدسي
    :: مراقب عام ::

  • فتحي القدسي
    رد
    فعلت جميع المستودعات ومع ذالك يرفض تثبيت الحزمه ....والسبب على مايبدوا حزمه البايثون القديمه
    خلاص نجح الامر باستثناء الحزم المتضاربه
    كود:
     [[email protected] ~]# yum -y install --skip-broken @arabic-support  
    Loaded plugins: langpacks, presto, refresh-packagekit
    Adding en_US to language list
    Setting up Install Process
    Package msttcore-fonts-2.0-3.noarch already installed and latest version
    Package paktype-tehreer-fonts-2.0-9.fc14.noarch already installed and latest version
    Package arabeyes-decorative-fonts-2.0.1-4.oj4.noarch already installed and latest version
    Package dejavu-sans-mono-fonts-2.32-1.fc14.noarch already installed and latest version
    Package kacst-fonts-2.01-2.oj4.noarch already installed and latest version
    Package arabeyes-core-fonts-2.0.1-4.oj4.noarch already installed and latest version
    Package paktype-naqsh-fonts-3.0-3.fc14.noarch already installed and latest version
    Package dejavu-sans-fonts-2.32-1.fc14.noarch already installed and latest version
    Package stardict-Babylon-ar-en-1-1.noarch already installed and latest version
    Package gtk2-immodule-xim-2.22.0-1.fc14.1.i686 already installed and latest version
    Resolving Dependencies
    --> Running transaction check
    ---> Package hijra-applet.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: hijra-python for package: hijra-applet-0.1.18-1.oj4.noarch
    ---> Package hunspell-ar.noarch 0:0.20080110-4.fc12 set to be installed
    ---> Package kde-i18n-Arabic.noarch 1:3.5.10-12.fc13 set to be installed
    ---> Package kde-l10n-Arabic.noarch 0:4.5.2-1.fc14 set to be installed
    --> Processing Dependency: kde-l10n = 4.5.2-1.fc14 for package: kde-l10n-Arabic-4.5.2-1.fc14.noarch
    ---> Package kfgqpc-fonts.noarch 0:0.08-1.oj4 set to be installed
    ---> Package stardict-Arabeyes-en-ar.noarch 0:1-1 set to be installed
    --> Running transaction check
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: python(abi) = 2.6 for package: hijra-python-0.1.18-1.oj4.noarch
    ---> Package kde-l10n.noarch 0:4.5.2-1.fc14 set to be installed
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: hijra-python for package: hijra-applet-0.1.18-1.oj4.noarch
    --> Running transaction check
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: python(abi) = 2.6 for package: hijra-python-0.1.18-1.oj4.noarch
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: hijra-python for package: hijra-applet-0.1.18-1.oj4.noarch
    --> Running transaction check
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: python(abi) = 2.6 for package: hijra-python-0.1.18-1.oj4.noarch
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Processing Dependency: hijra-python for package: hijra-applet-0.1.18-1.oj4.noarch
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package hijra-applet.noarch 0:0.1.18-1.oj4 set to be installed
    ---> Package hijra-python.noarch 0:0.1.18-1.oj4 set to be installed
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package hunspell-ar.noarch 0:0.20080110-4.fc12 set to be installed
    ---> Package kde-i18n-Arabic.noarch 1:3.5.10-12.fc13 set to be installed
    ---> Package kde-l10n.noarch 0:4.5.2-1.fc14 set to be installed
    ---> Package kde-l10n-Arabic.noarch 0:4.5.2-1.fc14 set to be installed
    ---> Package kfgqpc-fonts.noarch 0:0.08-1.oj4 set to be installed
    ---> Package stardict-Arabeyes-en-ar.noarch 0:1-1 set to be installed
    --> Finished Dependency Resolution
    
    Packages skipped because of dependency problems:
        hijra-applet-0.1.18-1.oj4.noarch from Local.Repo
        hijra-python-0.1.18-1.oj4.noarch from Local.Repo
        hijra-python-0.1.18-1.oj4.noarch from ojuba
        hijra-python-0.1.18-1.oj4.noarch from ojuba-testing
    
    Dependencies Resolved
    
    ====================================================================================
     Package                    Arch      Version                Repository        Size
    ====================================================================================
    Installing:
     hunspell-ar                noarch    0.20080110-4.fc12      Local.Repo       214 k
     kde-i18n-Arabic            noarch    1:3.5.10-12.fc13       Local.Repo       499 k
     kde-l10n-Arabic            noarch    4.5.2-1.fc14           fedora           2.4 M
     kfgqpc-fonts               noarch    0.08-1.oj4             Local.Repo       121 k
     stardict-Arabeyes-en-ar    noarch    1-1                    Local.Repo       2.1 M
    Installing for dependencies:
     kde-l10n                   noarch    4.5.2-1.fc14           fedora            15 k
    Skipped (dependency problems):
     hijra-applet               noarch    0.1.18-1.oj4           Local.Repo        22 k
     hijra-python               noarch    0.1.18-1.oj4           Local.Repo        27 k
     hijra-python               noarch    0.1.18-1.oj4           ojuba             27 k
     hijra-python               noarch    0.1.18-1.oj4           ojuba-testing     27 k
    
    Transaction Summary
    ====================================================================================
    Install       6 Package(s)
    
    Total download size: 5.3 M
    Installed size: 14 M
    Downloading Packages:
    Setting up and reading Presto delta metadata
    Processing delta metadata
    Package(s) data still to download: 5.3 M
    (3/6): kde-l10n-4.5.2-1.fc14.noarch.rpm                      |  15 kB     00:01     
    (4/6): kde-l10n-Arabic-4.5.2-1.fc14.noarch.rpm               | 2.4 MB     02:58     
    ------------------------------------------------------------------------------------
    Total                                                30 kB/s | 5.3 MB     03:01     
    Running rpm_check_debug
    Running Transaction Test
    Transaction Test Succeeded
    Running Transaction

    اترك تعليق:

يعمل...
X