إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

تثبيت التعريف المملوك من انفيديا على أبونتو 10.10

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [مشكلة] تثبيت التعريف المملوك من انفيديا على أبونتو 10.10

    السلام عليكم ورحمة الله وبركاته

    تحية طيبة وبعد

    في البداية المشكلة في كرت الشاشة

    اعمل على أبونتو 10.10إذا أردت تنصيب التعريف من
    additional drivers
    هناك خياران الإصدار 173
    عند تثبيته يصبح ريزيلوشن الشاشة
    640*480
    واستطيع تعديله منxrandr ويتحول المخرج منVGA-1
    إلىDefault

    أما في حالتنصيب تعريف ال
    current
    فبعد إعادة التشغيل يصبح لون الشاشة اسود واستطيع الدخول (أبدا)
    إلى النظام



    عند تنفيذ

    كود:
     [SIZE=4]
    uname -r
    [/SIZE]
    الناتج:
    كود:
    Linux rapier-pc 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:34:50 UTC 2010 i686 GNU/Linux
    وعند تنفيذ
    كود:
    ./compiz-check
    الناتج
    كود:
    Gathering information about your system...
    كود:
     [SIZE=4]  Distribution:          Ubuntu 10.10
     Desktop environment:   GNOME
     Graphics chip:         nVidia Corporation G86 [GeForce 9400 GT] (rev a1)
     Driver in use:         nouveau
     Rendering method:      AIGLX
    
    Checking if it's possible to run Compiz on your system...[/SIZE] [SIZE=4]
    
    [/SIZE] [SIZE=4]  Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [FAIL]
    
    There has been (at least) one error detected with your setup:[/SIZE] [SIZE=4]
     Error: Software Rasterizer in use
    [/SIZE]
    وعند تنفيذ:
    كود:
    lspci | grep VGA
    الناتج
    كود:
    01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 9400 GT] (rev a1)
    ارجوكم اريد الحل
    فيدورا 14جميلة ولكن لا اريد العودة إليها
    أعجبني أبونتو أكتر

    وأي استفهام أنا حاضر والسلام على من اتبع الهدى

  • #2
    يبدو انك تستعمل درايفر nouveau

    مكان nvidia

    ***************************
    Driver in use: nouveau
    ********************
    لتتأكد


    lsmod |grep nouveau
    lsmod |grep nvidia

    لتزيل درايفر nouveau


    sudo apt-get --purge remove xserver-xorg-video-nouveau

    ******************
    كما يستحسن ان تنصب الدرايفر من الموقع الاصلي - صيغة run


    http://ubuntuguide.net/install-latest-nvidia-graphics-drivers-in-ubuntu-linux

    http://www.socialblogr.com/2010/10/how-to-install-nvidia-graphic-card-driver-on-ubuntu-10-10.html



    The best way to learn linux is to use the command line whenever you can

    تعليق


    • #3
      اوووووووووف يا زمن

      في بادئ الأمر شكرا جزيلا اخي الكريم

      لقد قمت بتنفيد الامر الذي اخبرتني عنه

      كود:
      [COLOR=#000066]sudo apt-get --purge remove xserver-xorg-video-nouveau[/COLOR]
      ثم

      كود:
      
      
      كود:
      [SIZE=4][B]echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf [/B][/SIZE][SIZE=4][B][/B][/SIZE]



      ثم

      كود:
      
      
      كود:
      [SIZE=4][B]update-initramfs -u[/B][/SIZE][SIZE=4][B][/B][/SIZE]


      وبعد تحميل ملف التعريف الخاص بي من شركة انفيديا
      NVIDIA-Linux-x86-260.19.29

      و إغلاق الواجهة الرسومية والدخول إلى
      init 3




      كود:
      
      
      كود:
      [SIZE=4][B]chmod u+x NVIDIA-Linux-x86-260.19.29.run[/B][/SIZE][SIZE=4][B][/B][/SIZE]


      ثم

      كود:
      
      
      كود:
      [SIZE=4][B]sudo ./NVIDIA-Linux-x86_64-190.42-pkg2.run[/B][/SIZE][SIZE=4][B][/B][/SIZE]


      يظهر لي انني يجب ان أوافق على الإتفاقية فأوافق فيكتب لي التالي

      The distribution-provided pre-install script failed! Continue installation anyway??


      صراحة لم افهم معنى العبارة ولكن اعلم ان هناك خطا ما ولكن اخترت

      yes continue anyway


      فقام بتنصيب التعريف وكل الأمور تمام وبعد إعادة التشغيل

      كالعاااااااااااااااااااادة



      شاشة سوداء ولا خيار لدي أبدا

      باتنظارك اخي أنت والشباب الطيبون مثللك وشكرا سلفا

      والسلام على من اتبع الهدى

      تعليق


      • #4
        سؤال جربة تنزيل التعريف من مستودعات x اوبنتو


        انظر الرابط
        http://www.linuxac.org/forum/showthr...E6%E3%ED%C7%CA
        ((((استغفر اللــه العظيم الذي لا اله الا هو الحي القيوم وأتوب إليه ))))

        تعليق


        • #5
          قربت تنحل الأمور

          جزاك الله خيرا أخي عبد الله

          ما فعلته هو الآتي

          أولا ثبتت توزيعة أبونتو 10.10 من جديد

          ثانيا

          كود:
          
          
          كود:
          [SIZE=4]       [COLOR=#000066]sudo apt-get --purge remove xserver-xorg-video-nouveau[/COLOR]       
          [/SIZE]



          ثم

          كود:
          
          
          كود:
             [B][SIZE=4]echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf [/SIZE][/B]   [B][SIZE=4]
          [/SIZE][/B]


          ثم
          كود:
          
          
          كود:
             [B][SIZE=4]update-initramfs -u[/SIZE][/B]   [B][SIZE=4]
          [/SIZE][/B]



          ثم

          كود:
          
          
          كود:
             [B][SIZE=4]sudo add-apt-repository ppa:ubuntu-x-swat/x-updates[/SIZE][/B]   [B][SIZE=4]
          [/SIZE][/B]


          اييييييه ثم
          كود:
          
          
          كود:
             [B][SIZE=4]sudo apt-get update[/SIZE][/B]   [B][SIZE=4]
          [/SIZE][/B]


          وبعدها

          كود:
          
          
          كود:
             [B][SIZE=4]  sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings[/SIZE][/B]   [B][SIZE=4]
          [/SIZE][/B]


          يبدو لازم ننوع بين (ثم) و (وبعدها)


          المهم
          بدا بتحميل التعريف وكل الأمور زي الفل

          وبعد إعادة إقلاع الجهاز دخلت وإذ بالريزيلوشن كان رائع وعلى مقاس شاشتي
          كان
          1360*760
          جميل
          حاولت تفعيل المؤثرات ثلاثية الأبعاد قال لي
          Desktop Effects couldn't be abeled
          دخلت على
          additinol drivers
          ظهر لي تعريفين
          الأول إصدار 173 (غير مفعل)
          والثاني إصدار ال (current)
          بجانبه دائرة باللون الأخضر (مفعل) وتمام التمام

          اردت الدخول إلى
          nvidia-setting
          قال لي بما معناه بأنه يبدو أنني لم انزل تعريف الإنفيديا ويجب كتابته
          xorg.conf
          as root

          وهذا ما فعلته إلى الترمينال


          كود:
          xorg.conf
          فقال لي الترمينال بأن الإعدادات الجديدة قد حفظت داخل ملف ال
          xorg.conf

          أعدت التشغيل
          وللأسف الشديد
          الشاشة سوداااااااااااااااااء
          (ونهاري اليوم كان أسود)

          أعددت التشغيل ودخلت إلى النظام من الـ
          recovory mode

          ثم

          root

          ثم

          كود:
          cd /etc/X11/
          nano xconf.org
          وظهر لي محتويات هذا الملف
          ورايت القيمتين التاليتين:


          HorizSync : 28.0 - 33.0
          VertRefresh : 43.0 - 72.0

          ومن فترة كنت بحاول في التعريف أحدهم قال ان هاتين القيمتين يجب
          ان تطابق القيم الخاصة بالشاشة والتي نعرفها من تطبيق :

          كود:
          xvidtune
          فكان الناتج لدي:
          HorizSync 48.36 KHz
          VertRefresh 60 Hz


          أعتقد أن هذا كل ما لدي من معلومات أرجو أن تكون الأمور واضحة لديكم

          وان تستطيعوا (مشكورين) مساعدتي

          والسلام عليكم ورحمة الله وبركاته

          تعليق

          يعمل...
          X