إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

swaret: slackers Only (Slackware11 -> 12)

تقليص
X
 
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • أحمد-
    رد
    nice work StrikerX

    اترك تعليق:


  • StrikerX
    رد
    ماشى ياعم الملك lol
    اى خدمة ونورت^_^

    اترك تعليق:


  • Mohammed AL Jeaid
    رد
    امير = ملك


    تسلم يا احمد على المعلومات والموضوع المفيد لي ...


    تم التثبيت لفتره للفائده ..

    كل الود يا امير ^_^

    اترك تعليق:


  • StrikerX
    رد
    Gracies!
    بالمناسبة احمد مش امير :d

    اترك تعليق:


  • zAKoO Lord
    رد
    يعطيك العافية يا أمييييييييير


    تحياتي

    اترك تعليق:


  • Samir Aser
    رد
    بسم الله الرحمن الرحيم

    خالص الشكر والتقدير

    صباح الفُل

    اترك تعليق:


  • StrikerX
    كتب موضوع swaret: slackers Only (Slackware11 -> 12)

    swaret: slackers Only (Slackware11 -> 12)

    hola
    بما إنى مستخدم slackware11 فدا كان قبل الفترة بتاعت الإهتمام بال qt4 فالمهم اللى متركبة مع slackware هى qt3.3.6 وانا بشتغل على qt4
    وبكل بساطة حملت الإصدار الجديد وعملت كمبيل -حوالى ساعة ونص- اكتشفت conflict بين الlibs الموجودة واللى هدعمها فى ال path وإذا شلت qt3 بكل بساطة السيستم عندى so messed!

    بعد شوية بحث واسئلة و بما إن السبت اجازة فأنا قررت إنى اعمل upgrade لل slackware من 11 ل 12 وﻷنى هكسل احمل ديسترو واستبها وبتاع فالحل هو
    swaret
    إيه هى swaret ؟
    هى perl script بيستخدم فى عمل upgrade من الإصدار الحالى من slack للإصدار اللى إنت عايزه على سبيل المثال من 11 ل 12

    1- حمل ال script
    http://swaret.sourceforge.net/index.php

    2- ستبه بإستخدام installpkg
    كود:
    installpkg swaretXxX.tgz
    3- غير إسم ملف ال configuration بتاعها
    كود:
    cp /etc/swaret.conf.new /etc/swaret.conf
    واحد هيقول إنت إستخدمت cp مش mv ليه ؟ هقله عشان لما سعادتك ت mess configurations file up تلاقى عندك واحد سليم تقدر تستخدمه تانى!
    4- اعمل set لل version اللى عايز تعمل upgrade to
    كود:
    swaret --set VERSION=12.0
    5- افتح ملف ال /etc/swaret.conf لنظبط شوية حاجات
    تقدر تعمل set لل version فى الملف بس عادى بقة :ي

    6- فى قسم ال basic exclude ضيف alsa
    كود:
    EXCLUDE=alsa
    7- حول سطرى ال dep_root ل comments ضيف ليهم # قبلها
    كود:
    #DEP_ROOT=http://www.swaret.org/swaret
    #DEP_ROOT=ftp://ftp.swaret.org/swaret
    وحط مكانهم
    كود:
    DEP_ROOT=http://swaret.sourceforge.net/libraries-$VERSION
    لنخلص من مشاكل ال dependencies
    8- اعمل update لل packages list كالتالى
    كود:
    swaret --update
    اعمل automatic upgrade كالتالى
    كود:
    swaret --upgrade -a
    بالمناسبة تقدر تستب packages بردو كالتالى
    كود:
    swaret --install <pkgname>
    بالمناسبة فى tool تانية بإسم slackpkg بتقدم نفس الشئ وخيارات اوسع
    http://slackpkg.org/documentation.html
    ولكن خلاص بقة انا بدأت فى swaret
    happy upgrading.
    التعديل الأخير تم بواسطة StrikerX; الساعة 10-11-2007, 05:43 AM.
يعمل...
X